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Evaluation board/kit and Development tool important notice

1. This evaluation board/kit or development tool is designed for use for engineering evaluation, demonstration,
or development purposes only. Do not use it for other purposes. It is not intended to meet the requirements of
design for finished products.

2. This evaluation board/kit or development tool is intended for use by an electronics engineer and is not a
consumer product. The user should use it properly and in a safe manner. Seiko Epson dose not assume any
responsibility or liability of any kind of damage and/or fire coursed by the use of it. The user should cease to
use it when any abnormal issue occurs even during proper and safe use.

3. The part used for this evaluation board/kit or development tool may be changed without any notice.

NOTICE

No part of this material may be reproduced or duplicated in any form or by any means without the written
permission of Seiko Epson. Seiko Epson reserves the right to make changes to this material without notice.
Seiko Epson does not assume any liability of any kind arising out of any inaccuracies contained in this material
or due to its application or use in any product or circuit and, further, there is no representation that this material is
applicable to products requiring high level reliability, such as, medical products. Moreover, no license to any
intellectual property rights is granted by implication or otherwise, and there is no representation or warranty that
anything made in accordance with this material will be free from any patent or copyright infringement of a third
party. When exporting the products or technology described in this material, you should comply with the
applicable export control laws and regulations and follow the procedures required by such laws and regulations.
You are requested not to use, to resell, to export and/or to otherwise dispose of the products (and any technical
information furnished, if any) for the development and/or manufacture of weapon of mass destruction or for other
military purposes.

Arm, Cortex, Keil and pVision are registered trademarks of Arm Limited (or its subsidiaries) in the US and/or
elsewhere. IAR Systems, IAR Embedded Workbench, C-SPY, I-jet, IAR and the logotype of IAR Systems are
trademarks or registered trademarks owned by IAR Systems AB. SEGGER and J-Link are trademarks or
registered trademarks of SEGGER Microcontroller GmbH & Co. KG. All rights reserved.

All brands or product names mentioned herein are trademarks and/or registered trademarks of their respective
companies.

‘Reproduced with permission from Arm Limited. Copyright © Arm Limited”

©SEIKO EPSON CORPORATION 2021, All rights reserved.
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Overview

1. Overview

The S1C31 self-modifying library is a program for rewriting the program code and data in the built-in flash
memory of the target model from the application program. By linking this library to an application program and
calling a function, the flash memory can be erased and written.

This library and sample software are included in the S1C31xxx peripheral circuit sample software package. The
S1C31xxx peripheral circuit sample software package is available on Seiko Epson’s website.

In addition to this manual, please also refer to the "S1C31xxx Technical Manual".

1.1 Working Environment

The following is required when writing and debugging the sample software.
e Evaluation Board
- S5U1C31xxxTx evaluation board with SIC31 series.
e Debug Probes *1%2
- IAR Systems I-jet or SEGGER J-Link
e Integrated Development Environment
- IAR Embedded Workbench for ARM® (IAR EWARM) or MDK-ARM® (uVision)
e S1C31SetupTool package
- Includes Flash loader and Configuration files (.svd etc).
e  S1C31xxx Peripheral circuit sample software package
*1: Debug probes are not required for library function calls from the sample software.

*2: I-jet is available only with IAR EWARM. J-Link is available for both IAR EWARM and MDK-ARM.

For details on the above, refer to the attached manual.

1.2 Precautions for Usage

The S1C31 self-modifying library and sample software are for reference only. Our company will not take any
responsibility for any problems caused by this library. Please thoroughly verify the operation when using this
library for your product.

This manual is common to the self-modifying library provided for each model of the S1IC31 series. About the
specifications (Sector information and RAM usage, etc.) that differ depending on the model, refer to the readme
included in the S1C31xxx peripheral circuit sample software package.
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Library configuration

2. Library configuration

2.1 Folder Configuration

The configuration of the S1C31 self-modifying library, sample software, and related programs included in the
S1C31xxx peripheral circuit sample software package is as follows.

S1C31xxxSamplePKG_very_yy.zip
[S1C31xxxSamplePKG_very yy]

|- [Licenses]

|- [Drivers] : Drivers
|- [board] : Evaluation board related driver
|- [CMSIS] : CMSIS driver

| |- [Device]

| | |- [S1C31xxx]

| | |- [Include]

| | | |-S1C31xxx.h : CMSIS peripheral circuit access layer header file
[ I

| | |- [Source]

(. - [ARM]

(. - IAR]

| | | |- startup_S1C31xxx.s : CMSIS sartup program

| | |- system_S1C31xxx.c : CMSIS peripheral circuit access layer header program
| |- [Driver]

| | |- [Include]

| | | |- Driver_Common.h : Common driver definition

| | | |- Driver_Flash.h : CMSIS self-modifying library driver definition

[ I N AR

| | |- [Source]

I |- [SVD]

[sePeripheralLibrary] : Peripheral circuit library

[Middlewares] : Middlewares
|- [seEepromLibrary] : Self-modifying library
| |- [Device]
| | [- [S1C31xxx]
| | |- seFlashLibraryS1C31xxx.a : Library for IAR EAWRM
| | |- seFlashLibraryS1C31xxx.lib : Library for MDK-ARM
| |- flashLibraryForS1c31xxx_readme_e.txt : readme
| |- flashLibraryForS1c31xxx_readme_j.txt
|- ...
[Projects] : Sample softwares
- [Applications] : Various application software
|- [FLASH] : Sample software for Self-modifying library
| |- [ARM] : Project for MDK-ARM
| |- [IAR] : Project for IAR EWARM
| [- main.c
|- ...

|
README_e.txt

README_j.txt

Figure 2.1.1 S1C31xxx Sample software package configuration

2 Seiko Epson Corporation S1C31 Series Self-Modifying
Library Manual
(Rev.1.0)



Library configuration

2.2 Library function

The functions provided by this library are

defined in Drivers¥CMSIS¥Driver¥Include¥ Driver Flash.h. The

functions provided by this library are as follows.

Table 2.2.

1 Functions provided by this library

Function name

Functional overview

int32_t Initialize (ARM_Flash_SignalEvent_t cb_event) Initialization of this library

int32_t Uninitialize (void)

Restore the settings before initialization of this
library

int32_t EraseSector (uint32_t addr)

Erase built-in flash memory

int32_t ProgramData (uint32_t addr, const void *data, uint32_t cnt) Write built-in flash memory

int32_t ReadData (uint32_t addr, unsigned char *data, int32_t cnt) Read built-in flash memory

ARM_DRIVER_VERSION GetVersion (void) Get this library version

ARM_FLASH_INFO * GetInfo (void)

Get information on built-in flash memory

The verify function is also built into the ProgramData and EraseSector functions.

S1C31 Series Self-Modifying
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How to Use Library

3. How to Use Library
Explains how to use the S1C31 self-modifying library and sample software.

3.1 How to Use Library in Application Program

This section describes how to use this library on the application program. For how to incorporate the library into
the project of an application program, refer to “Appendix x. How to Incorporate Library into Project.”

1. Declaration of Header File

Include “Driver Flash.h” in the source file that uses this library.

/* include */

#include <stdio.h>
#include <string.h>
#include "Driver Flash.h"

2. Add function

Add the functions provided by the library to the source file that uses this library. About the function specifications,
refer to "Chapter 4 Library Specifications".

extern _ARM DRIVER FLASH Driver Flash;

int main(void)
{
unsigned char compbuf[16];

Disable interrupts in peripheral

//disable Interrupt
asm("CPSID i");

ARM FLASH INFO *Info = Driver Flash.Getlnfo();

Driver_Flash.GetVersion(); . e e . o
ver— 0; Library initialization (initialization of peripheral circuits

//Initialize to be used)
Driver Flash.Initialize(NULL),

J/Erase at 0x D000 / Erase built-in flash memory
if (Driver_Flash.EraseSector(0x1D000)==ARM_DRIVER_ OK)
{
printf("Erase: OK¥n"); Write built-in flash memory
//Write at 0x1D000
if (Driver_Flash.ProgramData(0x1D000, updateLineBit,16Y>=ARM_DRIVER OK)
{
printf("Program: OK¥n");
//Read at 0x1D000 / Read built-in flash memory
Driver Flash.ReadData(0x1D000, compbuf, 16);

if (memcmp(updateLineBit, compbuf, 16) == 0) {
printf(" Verify: OK¥n");
}else {
printf("Verify: NG¥n");
)
} else {
printf("Program: NG¥n");

}
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How to Use Library

}else {
printf("Erase NG¥n");

}

printf("Exit¥n");

//Uninitialize Restore the settings before initialization of this library
Driver Flash.Uninitialize()

//enable Intemll?t Enable interrupts in peripheral circuits
asm("CPSIE 1" )~

return 0;

H
3.2 Internal RAM Usage

This library uses an internal RAM area. About the RAM usage of the self-modifying library of each model, refer to
the readme included in the S1C31xxx peripheral circuit sample software package.

3.3 Precautions for Using Library

When using this library, be careful about the followings:

Disable interrupts before using the functions provided by this library.

Do not destruct the area where the library is laid out while executing this library.

When using this library, be aware of rewritable count of flash memory. For information about flash

memory specification, refer to corresponding "S1C31xxx Technical Manual".

When using this library, stop all peripheral circuits. This library works as follows:

1. The S1C31D01/S1C31D5x/S1C31W74 uses 16bit timer (T16) ch.0. Therefore, the register of 16bit timer,
ch.0 is changed. Be aware when application program uses the 16bit timer.

2. The system clock is changed to High-Speed clock (OSC3 or IOSC) in using the library. Be aware when a
program uses CLG Control Register in using the library.

About the specifications (Sector information and RAM usage, etc.) that differ depending on the model,

refer to the readme included in the S1C31xxx peripheral circuit sample software package.

When using this library, connect a capacitor to the Vpp pin as shown in the basic external connection

diagram in "S1C31xxx Technical Manual", and disconnect the connection between the Vpp pin and other

pin.

S1C31 Series Self-Modifying
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How to Use Library

3.4 Sample Software

1. Sample Software Specification
In this sample software, this library is used to erase the sector at address 0x1D000 and then write 16 bytes.

2. Preparation
For details on how to execute this sample software project, refer to the "S1C31xxx Peripheral Circuit Sample
Software Manual".

3. Operations Overview

(1) Disables interrupts in peripheral circuits.

(2) Get the information on the internal flash memory. (Optional)

(3) Get the version of this library. (Optional)

(4) Initialize this library. (Initialization of peripheral circuits used)

(5) Erase in internal flash memory (0x1D000).

(6) Write the update data updateLineBit[] (16byte) to internal flash memory (0x1D000).

The data of 0x1D000 after rewriting is as follows.

OF OE 0D 0C 0B 0A 09 08 07 06 05 04 03 02 01 00

(7) Read the internal flash memory (0x1D000).

(8) Compare the read data cmpbuf [] with the update data updateLineBit [] and display the result.
(9) Restore the settings before initialization of this library.

(10) Enables interrupts in peripheral circuits. (Optional)

Seiko Epson Corporation S1C31 Series Self-Modifying
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4. Library Specification

4. Library Specification

41 Library Function Details

The details of the functions provided by this libra are described below.

Function Name
int32_t Initialize (ARM_Flash_SignalEvent_t cb_event)

Argument

cb_event | ARM_Flash_SignalEvent_t | Normally set to NULL
Return Value

int32_t | ARM_DRIVER_OK (0)
Function

Initialize the peripheral circuits used in this library.
(1) Change the system clock
(2) Initialize of T16 Ch.0 (S1C31D01/S1C31D5x/S1C31W74 only)

Remarks

Disable interrupts in peripheral circuits before using this function.

Function Name
int32_t Uninitialize (void)
Return Value
int32_t | ARM_DRIVER_OK (0)

Function

Restore the settings before initialization with the Initialize function.
(1) SetT16 Ch.0 (S1C31D01/S1C31D5x/S1C31W74 only)
(2) Change the system clock

Remarks

If necessary, allow interrupts in peripheral circuits after using this function.

Function Name
int32_t EraseSector (uint32_t addr)

Argument

addr | uint32_t Start address of erase sector

Return Value

int32_t | Erase result (error code)

Function

Erase the internal flash memory.

(1) Check that the argument is less than or equal to the final address of the internal flash memory.

(2) Check if the erased sector has been erased (0xffff).

(3) When (2) is not erased, the sector is erased.

(4) When erasing is executed in (3), check whether the erase destination sector has been erased (0xffff). (Verify)
(5) Returns the erasure result.

Remarks
1. Erasing of this function is “one sector” units. To erase multiple sectors, call this function multiple
times.

S1C31 Series Self-Modifying
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4. Library Specification

Disable interrupts in peripheral circuits before using this function.

Specify the start address of the sector in the argument. If you specify an address other than the
start address of the sector, a verification error may occur.

4. For sector information, refer to the readme included in the S1C31xxx peripheral circuit sample
software package.

wn

Function Name

int32_t ProgramData (uint32_t addr, const void *data, uint32_t cnt)

Argument
addr uint32_t Write address.
Write data.
data const void * Represents a pointer to the write data. The pointer should
point the RAM space.
cnt uint32_t Write data size.
Return Value
uint32_t Write result (error code)

Function

Write the internal flash memory.

(1) Check that the argument is less than or equal to the final address of the internal flash memory.
(2) Write data to the specified write address.

(3) Check if the write address is write data. (Verify)

(4) Returns the writing result.

Remarks

1. Writing of this function is in "byte (8bit)" units.
2. ltis assumed that the writing destination has been erased (0xffff).
3. Disable interrupts in peripheral circuits before using this function.

Function Name

int32_t ReadData (uint32_t addr, unsigned char *data, int32_t cnt)

Argument
addr uint32_t Read address.
Read data.
data const void * Represents a pointer to the read data. The pointer should
point the RAM space.
cnt uint32_t Read data size.

Return Value

uint32_t ARM DRIVER_OK (0)

Function

Read the internal flash memory.

(1) Check that the argument is less than or equal to the final address of the internal flash memory.
(2) Read to the specified read address.

(3) Returns the reading result.

Remarks

1. Reading of this function is in "byte (8bit)" units.
2. Disable interrupts in peripheral circuits before using this function.
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4. Library Specification

Function Name

ARM_DRIVER_VERSION GetVersion (void)

Return Value

ARM_DRIVER_VERSION Version of this library

Function

Get version of this library

Remarks

None.

Function Name

ARM_FLASH_INFO * Getlnfo (void)

Return Value

ARM_FLASH_INFO * | Information of the internal flash

Function

Get information of the internal flash.
e  Sector number
e  Sector size

Remarks

None.

4.2 Error Code Definition

The error code used in the return value of each function is as follows.

Table 4.2.1 Error Code

Definition Name Value Description
ARM_DRIVER_OK 0 Successful completion
ARM DRIVER_ERROR TIMEOUT -3 Time out / Verify error
ARM_DRIVER_ERROR_UNSUPPORTED -4 Unsupported operation
ARM DRIVER ERROR PARAMETER -5 Argument error

These are defined in “Drivers¥CMSIS¥Driver¥Include¥Driver Common.h”.
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Appendix

Appendix

A. How to Incorporate Library into Project (IAR EWARM)

The method of incorporating this library into the project of the application program created by IAR EWARM is
described below. For more information on IAR EWARM, please refer to the attached manual.

1. Add Library

(1) Select [Project]> [Options] from the IAR EWARM menu.
(2) Select [Linker] from the [Category] list in the displayed dialog.

(3) From the [Library] tab, add this library included in the S1C31xxx peripheral circuit sample software
package to "Additional libraries".

Middlewares¥seFlashLibrary¥Device¥S1C31xxx¥seFlashLibraryS1C31xxx.a

% Flash - IAR Embedded Warkbench IDE - Arm

Options for node "Flash”

File Edit WView Project J-link Tools Window Help
+ 7 | K|y )
NOLRE e L% G C SN
Categary: 5
Waorkspace ¥ 0 X | mainc x Factory Settings
G | Opti ~
DebugFlash i Ent.ara P ?ns
T Static Analysis
Files & . ? AAAAAAAAAAAA Runtime Checking P - - _ .
[83] Fiash - DebugFlash - CJC++ Compiler #define . Diagnostics Checksum Encodings Extra Options
B board Assembler Con(3) Input Optimizations = Advanced Output List
B CMSIS M Output Converter
= ’ ake . . " . .
W sePeripherallibrary — b Custom Build [] Automatic runtime library selection
main.c Sl r Build Actions Additional libraries: (one per ling)
= Outpui Rebuild Al r (2) $PROJ_DIR$¥. ¥ ¥ ¥ ¥Middlewares¥seFlashLibrary¥Device¥S103 1000 D
Clean [ Debugger
C-STAT Static Analysi > | Simator
- ic Analysis
g 1 CADIL
Stop Build CMSLS DAP
GDB Server [[]Override default program entry
Add > Ijet Entry symbol __iar_program_start
Remove | JHink/J-Trace No entry symbol
i I Stellaris
Rename... NuLink
Version Control System > PE micro
i STLINK
Flash Open Containing Folder.. Third-Party Driver
Debug Log File Properties... et e
| Log Set as Active
Cancel

Figure A.1 Add library

2. Addinclude path

(1) Select [Project]> (1) IAR EWARM menu [Project]> [Options] from the IAR EWARM menu.

(2) Select [C / C++ Compiler] from the [Category] list in the displayed dialog.

(3) From the [Preprocessor] tab, add the following include path of the driver definition

included in the S1C31xxx peripheral circuit sample software package to the "Additional
include directory".
Drivers¥CMSIS¥Driver¥Include
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2 Flash - IAR Embedded Workbench IDE - Arm

Options for node "Flash"

File Edit View Project J-link Tools Window Help

DORR = XRE D C -l £ Q2
Category: F St
‘Waorkspace * I X  mainc x actory Settings
General Options ~ [ Multifile Compilation
DebugFlash > Static Analysis Discard Unused Publics
N Shk
Files - SR T | Runtime Checkin
2) MISRA-C:1998 Encodings Extra Opticns

L
[ DEhUQFIﬂSh Assembler Language 1 Language 2 Code Optimizations Output
HChSIS Maks Qutput Converter List (3) Diagnostics MISRA-C:2004
laKe
7]
g
r

i zePeripherallibran, Custom Build
main.c Compile Build Actions [Tignore standard include directories
B Output Rebuild All Linker Additicnal include directories: (one per ling)
Clean Debugger $TOOLKIT_DIR$¥inc¥Epson¥ ~ D
. Simulator $PROJ_DIRS¥. 4L ¥ ¥Drivers¥CMSIS¥Device¥S1C31D01¥Inc lude
C-STAT Static Analysis > ! cADI $PROJ DIRSY. ¥, ¥ ¥ ¥Drivers¥CMSIS¥Driver¥include¥
- CMSIS DAP $PROJ_DIRS¥. ¥.¥ ¥ ¥Drivers¥sePeripheralLibrary¥
Stop Build DB Server $PROJ_DIRS¥. ¥.¥.¥ ¥Drivers¥board¥S5U1C31D01T1¥ v
Add > Ijet Preinclude file:
o I-Link(1-Trace |
smove ¢ I Stellaris
Rename... Nu-Link Defined symbeols: (cne per ling)
B i P itput to fil
Version Control System > PE micro S1C21bo1 [ Preprocessor output o file
b STLINK Preserve comments
Flash ‘Open Containing Folder... Third-Party Driver v Generate #line directives
B File Properties... e
| Log Set as Active

Cancel
Figure A.2 Add include path

3. Set linker script

(1) Edit the linker script file (.icf) included in the project.

(2) S1C31xxx Peripheral circuit sample software package Add the following section by referring to the sample
software linker script file (S1C31xxx_fp_flash.icf) included in the package.

*###ICF### Section handled by ICF editor, don't touch! ****/

initialize by copy { readwrite }; Generate flash_common_tex section

initialize manually with packing = none { section .flash common_text};

//initialize by copy with packing = none { section DLIB PERTHREAD }; // Required in a multi-threaded
application

do not initialize { section .noinit };

place at address mem: ICFEDIT intvec_start  { readonly section .intvec };

place in ROM region  { readonly };

place in RAM region  { readwrite, Specifying the copy source section of the
block CSTACK, block HEAP }; ROM area

place in ROM region  { section .flash_common_text 4nit}; Specifying the copy destination section of the

place in RAM region  { section .flash common_text +: RAM area

Add the above and place the code of this library in the RAM area.
(3) Select [Project]> [Options] from the IAR EWARM menu.
(4) Select [Linker] from the [Category] list in the displayed dialog.
(5) Check "Override default " from the [Config] tab and specify the edited linker script file.
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© Flash - IAR Emb Options for node "Flash”

File Edit View Project J-Link Tools Window Help

DO M@ = XE[NIDC -1 Q2

Category: 5
Warkspace v & X | mainc x Factory Settings
General Options ~
DebugFlash el Static Analysis
Files . Runtime Checking
FARELEL RS ’ Hdefine Diagnostics Checksum Encodings Extra Options
[€)] Fiash - DebuaFlash C/C-++ Compler
. board d [ Assembler Library  Input Optimizations ~ Advanced Output  List
& oar ’
HCHSIS Mak Output Converter Linker configuration file
— - . ake
M sePeripherallibrary o B Custom Buid [Flovenide default
main.c Loz b Build Actions :
i Output Rebuild All (1) | 3PROJ_DIR$¥config¥51C31001_fp_flash.icf ‘m
Clean F Debugger :
Simulator Edit...
C-STAT Static Analysis » |l CADI
Stop Build CMSIS DAP Configuraticn file symbel definitions: (one per line)
Stop Build
G GDB Server
Add > Ijet
Idink/1-Trace
Remove g TI Stellaris
Rename... Mu-Link
1 PE mi
Version Control System 'k miere
ST-LINK
Flash Open Containing Folder... Third-Party Driver
Debug Log File Properties...
c o A r
| Log Set as Active
Cancel
Figure A.3 Set linker script
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B. How to Incorporate Library into Project (MDK-ARM)

The method of incorporating this library into the project of the application program created MDK-ARM (uVsion)
is described below. For more information on MDK-ARM, please refer to the attached manual.

1. Add Library

(1) Right-click the target source folder from the [Project] window of uVision and select [Add Existing Files to
Group ‘xxx’...].

(2) From the displayed dialog, add this library included in the S1C31xxx peripheral circuit sample software
package below.

Middlewares¥seFlashLibrary¥Device¥S1C31xxx¥seFlashLibraryS1C31xxx.lib

('
File Edit View Project Flash Debug Peripherals Tools
= A
¥ LoAD g
[EARE1 > 2 ¥4 | DebugFlash v &4
Project 18
=% Project: flash
-l s DebugFlash
o EEsd
j A\ Options for Group ‘SRC'... Alt-F7
A Add New Item to Group 'SRC'...
isting Files to Group
J Add Existing Files to G SRC
J i Remove Group "SRC' and its Files
# [ boal
* sePe [*¥] Rebuild all target files
L
& cm |¥] Build Target F7
i Manage Project [tems...
v | Show Include File Dependencies
Eproject | {} Functions | DT

Figure B.1 Add library

2. Addinclude path

(1) Select [Project]> [Options for Target ‘xxx’...] from the uVision menu.

(2) Browse to the folder from [C / C ++]> ‘Include Paths’ in the displayed dialog.

(3) From [New (Insert)], add the following include path of the driver definition included in the S1C31xxx
peripheral circuit sample software package.
Drivers¥CMSIS¥Driver¥Include
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(W) K4 options for Target 'DebugFlash'’ @ %
File Edit \(1) Fiash; Debug_ Peripherals Device | Target | Output | Listing | User Asm | Linker | Debug | Utilities |
B J New pVision Project...
& @y 2 New Multi-Project Workspace.., Preprocessor Symbols
| &2 1
— Open Project... Define: fS1C31 XXX
oje
Jl - Close Project Undefine: I
= "3 Project: flast
- 45 DebugFl Export Language / Code Generation
=& SRC Manage [~ Execute-only Code I Stict ANSIC Wamings: m
Qs Select Device for Target Optimization: |Level 0(00) ~ [~ Enum Container always int =
j 1 e e [~ Optimize for Time ™ Plain Charis Signed ™ No Auto Includes
s gl :
- i i v
m sI 2. Options for Target DebugFlash's, [~ Split Load and Store Muttiple ™ Read-Only Position Independent [V €99 Mode
[~ One ELF Section per Function [~ Read-Write Posttion Independent [~ GNU extensions
# (4 boar Clean Targets
B3 sePe 141 gl Target Include | ¥ ¥ ¥ ¥Drivers¥board¥S5U1C31xxxT1:. ¥. ¥. ¥. ¥Drivers¥CMSIS¥Device¥S1C31 xxx¥include:.. |
o [ Build Targe s | FEERE RARR . Bl
%4 Rebuild all target files Misc I
& Batch Build Lo
@ Batch Setup Compiler |99 < —cpu Cortex-M0+ -D__EVAL i -g 00 -apcs=interwork -| .. -|
control |./././. /Drivers/board/S5UTC31xxx T1 ../../. /. /Drivers/CMSIS/Device/S1C3 1xxx /include -
Translate... string
Stop build
I oK I Cancel Defaults Help

Folder Setup

Setup Compiler Include Paths: 3) X T+

.¥.¥ ¥ ¥Drivers¥board¥S5U1C31xxxT1

¥ ¥ ¥ ¥Drivers¥CMSIS¥Device¥S1C31xxx¥Include
¥ ¥ ¥ ¥Drivers¥sePeripherallLibrary

_¥_¥ ¥ ¥Drivers¥sePeripheralLibrary¥Device¥S1C31xxx
_¥ ¥ ¥ ¥Drivers¥CMSIS¥Driver¥Include

I OK |I Cancel

Figure B.2 Add include path

3. Set linker script

(1) Edit the linker script file (.sct) included in the project.

(2) Add the following section by referring to the linker script file (flash_flash.sct) of the sample software
included in S1C31xxx Peripheral circuit sample software package.

« 3 sk sk sk sk sk sk sk sk sk sk sk sk sk sk ok ok ok ok ok ok ok ok ok ok sk ok sk sk sk sk sk sk sk sk st sk sk sk sk sk sk ok ksl sk sk sk sk sk sk sk sk sk ko sk ke ko ok
>

; ¥** Scatter-Loading Description File generated by uVision ***
o 3fe sk st sfe sk sk sk sk sfe sk sie sk sk she sk sk sk sk sk sk ke sk sk sk sk sk sk sk sl sl sk sk sk ske sk sk sk sk sk e st sk sfe sl sk sk sfe sk sk sk sk skeoskoske sk seskokok sk
2

RW_IRAMI1 0x00150000 { ; RW data
ANY (+RW +ZI)

}

RW _IRAM2 +0 { ;RW data Generate flash_common_text section in RAM area
*(.flash_common_text)

}

In this library, place the code of this library in the RAM area.
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Appendix

(3) Select [Project]> [Options for Target ‘xxx’...] from the uVision menu.
(4) Specify the linker script file edited from [Linker]> ‘Scatter File’ in the displayed dialog.

W)

File Edit \(3) | Project | Flash Debug Peripherals

E A

Project
= % Project: flast
=l %3 DebugFl
= SRC
s

MNew pVision Project...

New Multi-Project Workspace...
Open Project...

Close Project

Export

Manage

Select Device for Target ...

Remove ltem

« Options for Target 'DebugFlash'... I

Clean Targets

Build Target

Rebuild all target files
Batch Build

Batch Setup...

Translate...

Stop build

QOptions for Target ‘DebugFlash’

(4)

Device | Tareet | Output | Listing | User | G/G++ | Asm Debug | Utilities |

™ Use Memory Layout from Target Dialog

[~ Make RW Sections Position Independent
[~ Make RO Sections Posttion Independent
™ Dont Search Standard Libraries

[V Report ‘might fail' Conditions as Emors

Scatter

Misc
controls

Linker
control
string

X/0 Base:
R/O Base:
R/W Base

disable Wamings: [

¥flash_flash sct

jD Edit..

—cpu Cortex-M0+ * .0
—strict ~scatter " ¥flash_flash.sct"

o1

Cancel Detaults

Help

Figure B.3 Set linker script
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