CMOS 32-BIT SINGLE CHIP MICROCONTROLLER

S1C31 Family
Software Development Setup Guide

ARM®

SEIKO EPSON CORPORATION
Rev.3.0
Evaluation board/kit and Development tool important notice

1. This evaluation board/kit or development tool is designed for use for engineering evaluation, demonstration, or development purposes only. Do not use it for other purposes. It is not intended to meet the requirements of design for finished products.

2. This evaluation board/kit or development tool is intended for use by an electronics engineer and is not a consumer product. The user should use it properly and in a safe manner. Seiko Epson does not assume any responsibility or liability of any kind of damage and/or fire caused by the use of it. The user should cease to use it when any abnormal issue occurs even during proper and safe use.

3. The part used for this evaluation board/kit or development tool may be changed without any notice.

NOTICE

No part of this material may be reproduced or duplicated in any form or by any means without the written permission of Seiko Epson. Seiko Epson reserves the right to make changes to this material without notice. Seiko Epson does not assume any liability of any kind arising out of any inaccuracies contained in this material or due to its application or use in any product or circuit and, further, there is no representation that this material is applicable to products requiring high level reliability, such as, medical products. Moreover, no license to any intellectual property rights is granted by implication or otherwise, and there is no representation or warranty that anything made in accordance with this material will be free from any patent or copyright infringement of a third party. When exporting the products or technology described in this material, you should comply with the applicable export control laws and regulations and follow the procedures required by such laws and regulations. You are requested not to use, to resell, to export and/or to otherwise dispose of the products (and any technical information furnished, if any) for the development and/or manufacture of weapon of mass destruction or for other military purposes.

All brands or product names mentioned herein are trademarks and/or registered trademarks of their respective companies.

ARM and Cortex are registered trademarks of ARM Limited (or its subsidiaries) in the EU and/or elsewhere. IAR Systems, IAR Embedded Workbench, C-SPY, I-jet, IAR, and the IAR Systems logotype are trademarks or registered trademarks owned by IAR Systems AB. All rights reserved.

“Reproduced with permission from ARM Limited. Copyright © ARM Limited”

©SEIKO EPSON CORPORATION 2019, All rights reserved.
Table of Contents

1. Overview .......................................................................................................................... 1

2. Acquisition of Development Environment ............................................................... 2
   2.1 Acquisition Route ......................................................................................................... 2
   2.2 Documents for Referencing Detailed Information ...................................................... 3

3. Setup of Development Environment ........................................................................ 4
   3.1 Installation of IDE ....................................................................................................... 4
       3.1.1 When Using the IAR EWARM ........................................................................ 4
       3.1.2 When Using the MDK-ARM ........................................................................... 5
   3.2 Connection of Hardware ............................................................................................ 6
       3.2.1 When Using the I-jet ....................................................................................... 6
       3.2.2 When Using the J-Link ..................................................................................... 7

4. Software Development and Evaluation .................................................................... 9
   4.1 Setup of Sample Software .......................................................................................... 9
   4.2 Build and Debug of Software ................................................................................... 11
       4.2.1 When Using the IAR EWARM ....................................................................... 11
       4.2.2 When Using the MDK-ARM ........................................................................... 15

Revision History ............................................................................................................. 24
1. Overview

This document is intended to guide the user in using the S1C31 Family\(^*1\) for the first time to quickly set up the environment to start software development and evaluation.

*1: S1C31 Family is a microcontroller equipped with ARM\(^\text{\textregistered}\) Cortex\(^\text{\textregistered}\)-M0+ processor and is a product of Seiko Epson Corporation.

Table 1.1 shows all software development steps and reference manuals for each of the development steps.

Table 1.1 Software Development Steps and Reference Manuals

<table>
<thead>
<tr>
<th>Development steps</th>
<th>Reference manuals *2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Acquisition of Development Environment</td>
<td>- This document(Chapter 2)</td>
</tr>
<tr>
<td>Setup of Development Environment</td>
<td>- This document(Chapter 3)</td>
</tr>
<tr>
<td>- Installation of IDE</td>
<td>- S5U1C31xxxTx Manual</td>
</tr>
<tr>
<td>- Connection of Hardware</td>
<td>- S5U1C31001L1200 (Bridge Board Ver.2) Manual</td>
</tr>
<tr>
<td>Software Development and Evaluation</td>
<td>- This document(Chapter 4)</td>
</tr>
<tr>
<td>- Setup of Sample Software</td>
<td>- S1C31xxx Peripheral Circuit Sample Software Manual</td>
</tr>
<tr>
<td>- Build and Debug of Software</td>
<td>- S1C31xxx Technical Manual</td>
</tr>
</tbody>
</table>

*2: Please download from the Seiko Epson microcontroller web site.
2. Acquisition of Development Environment

This chapter describes the environment for software development and evaluation.

2.1 Acquisition Route

The user can use the third-party ARM® development tools (Integrated Development Environment /IDE and Debug Probe) to develop and evaluate the software for the S1C31 Family.

Table 2.1.1 shows the recommended development tools for S1C31 Family. Please contact the tool vendors or the tool vendor’s distributors to obtain these tools.

<table>
<thead>
<tr>
<th>Type</th>
<th>Name</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>PC</td>
<td>PC with Windows 7/8.1/10</td>
<td>-</td>
</tr>
<tr>
<td>Integrated Development Environment (IDE)</td>
<td>IAR Embedded Workbench for ARM (by IAR Systems)</td>
<td>Please prepare either one.</td>
</tr>
<tr>
<td></td>
<td>MDK-ARM with uVision5 (by ARM)</td>
<td></td>
</tr>
<tr>
<td>Debugging Probe</td>
<td>I-jet (by IAR Systems)</td>
<td>Please prepare either one.</td>
</tr>
<tr>
<td></td>
<td>J-Link (by SEGGER)</td>
<td></td>
</tr>
</tbody>
</table>

Please prepare either one of IDEs and either one of debug probes in Table 2.1.1. However, please note that some combinations of IDE and debug probe can not be used as shown in Table 2.1.2.

<table>
<thead>
<tr>
<th>IDE/Debug Probe</th>
<th>Available Combinations</th>
</tr>
</thead>
<tbody>
<tr>
<td>IAR Embedded Workbench for ARM (IAR EWARM)</td>
<td>I-jet Available J-Link Available</td>
</tr>
<tr>
<td>MDK-ARM</td>
<td>Not available Available</td>
</tr>
</tbody>
</table>

Also by using sample software and evaluation board provided by Seiko Epson with above tools, it is easy for the user to start software development and evaluation.

Table 2.1.3 shows the development tools provided by Seiko Epson.

<table>
<thead>
<tr>
<th>Type</th>
<th>Name</th>
<th>Remarks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sample Software</td>
<td>S1C31xxx Peripheral Circuit Sample Software *1</td>
<td>-</td>
</tr>
<tr>
<td></td>
<td>Ex. S1C31D01 Peripheral Circuit Sample Software</td>
<td></td>
</tr>
<tr>
<td>Evaluation Board</td>
<td>S1C31xxx Evaluation Board (S5U1C31xxxxTx) *2</td>
<td>-</td>
</tr>
<tr>
<td></td>
<td>Ex. S1C31D01 Evaluation Board(S5U1C31D01T1)</td>
<td></td>
</tr>
</tbody>
</table>

*1: Please download from the Seiko Epson microcontroller web site.
*2: Please contact your local distributor or sales office.
2. Acquisition of Development Environment

2.2 Documents for Referencing Detailed Information

This setup guide shows the documents for referencing detailed information accordingly. Table 2.2.1 lists these documents.

Table 2.2.1 List of Reference Document

<table>
<thead>
<tr>
<th>Tool</th>
<th>Reference information</th>
<th>Reference document</th>
</tr>
</thead>
<tbody>
<tr>
<td>IAR EWARM</td>
<td>Installation</td>
<td>Quick Reference *1</td>
</tr>
<tr>
<td></td>
<td>IDE operations</td>
<td>Getting Started with IAR Embedded Workbench for ARM *1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>IDE Project Management and Building Guide *1</td>
</tr>
<tr>
<td></td>
<td></td>
<td>C-SPY® Debugging Guide *1</td>
</tr>
<tr>
<td>MDK-ARM</td>
<td>Installation</td>
<td>Getting Started with MDK *2</td>
</tr>
<tr>
<td></td>
<td>IDE operations</td>
<td>Getting Started with MDK *2</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Complete User's Guide Selection</td>
</tr>
<tr>
<td>I-jet</td>
<td>-</td>
<td>IAR Debugging probes User Guide *1</td>
</tr>
<tr>
<td>J-Link</td>
<td>-</td>
<td>J-Link/J-Trace User Guide *3</td>
</tr>
<tr>
<td>S1C31xxx Peripheral Circuit Sample Software</td>
<td>-</td>
<td>S1C31xxx Peripheral Circuit Sample Software Manual *4</td>
</tr>
<tr>
<td>S1C31xxx Evaluation Board</td>
<td>-</td>
<td>S5U1C31xxxTx Manual *4</td>
</tr>
<tr>
<td></td>
<td></td>
<td>S5U1C31001L1200 (Bridge Board Ver.2) Manual *4</td>
</tr>
</tbody>
</table>

*1: Please download from the IAR Systems web site.
The URL of this web site is as follows: <https://www.iar.com/>

*2: Please download from the ARM KEIL web site.
The URL of this web site is as follows: <http://www.keil.com/>

*3: Please download from the SEGGER web site.
The URL of this web site is as follows: <https://www.segger.com/>

*4: Please download from the Seiko Epson microcontroller web site.
3. Setup of Development Environment

This chapter describes the procedure to set up the software development environment for the S1C31 Family.

3.1 Installation of IDE

This section describes the procedure to install IAR EWARM and MDK-ARM.

3.1.1 When Using the IAR EWARM

Install the IAR EWARM by following the procedure shown below.

1. Download the installer of IAR Embedded Workbench for ARM from the web site of IAR Systems.
2. Finish all the application on the Windows.
3. Double click the installer (exe file) to launch it. Then the installation screen shown below will be displayed. (Figure 3.1.1.1)
4. Click [Install IAR Embedded Workbench®] to start the installation wizard. (Figure 3.1.1.1)

![Installation Screen of IAR Embedded Workbench for ARM](image)

Figure 3.1.1.1 Installation Screen of IAR Embedded Workbench for ARM

5. Follow the prompts in the installation wizard to proceed with the installation. The recommended settings are as follows.
   - Installation directory: Default location
   - Installation option: Full installation

If you launch the IAR Embedded Workbench for the first time after installation, license registration will be requested. The procedure of license registration varies depending on the type of license you purchased. For more information on the procedure of license registration, refer to “Quick Reference” (listed in Table 2.2.1).
3.1.2 When Using the MDK-ARM

Install the MDK-ARM by following the procedure shown below.
(1) Download the installer of MDK-ARM from the ARM web site.
(2) Finish all the application on the Windows.
(3) Double click the installer (exe file) to launch it. Then the installation wizard shown below will be displayed.
   (Figure 3.1.2.1)

   ![Installation Screen of MDK-ARM](image)

   Figure 3.1.2.1 Installation Screen of MDK-ARM

(4) Follow the prompts in the installation wizard to proceed with the installation of MDK Core. The recommended settings are as follows.
   - Installation directory: Default location

(5) Pack Installer is started automatically after the installation MDK Core, select [cortex-M0 plus] to install the software pack for “cortex-M0 plus”.

If you use MDK-ARM without code size limits after installation, license registration is required. The procedure of license registration varies depending on the type of license you purchased. For more information on the procedure of license registration, refer to “Getting Started with MDK” (listed in Table 2.2.1).
3. Setup of Development Environment

3.2 Connection of Hardware

This section describes how to connect the hardware of the software development. The debug probe recommended for the S1C31 Family is I-jet or J-Link.

3.2.1 When Using the I-jet

(1) Connect I-jet to the PC with IAR EWARM installed using the USB micro cable included with I-jet. This enables the PC to automatically install the device driver.

(2) Connect I-jet to the evaluation board (ex. S5U1C31xxxTx) using the MIPI-20 cable and ARM-20 adapter included with I-jet. (see Figures 3.2.1.1)

![Figure 3.2.1.1 Hardware Connection using I-jet](image)

Figure 3.2.1.1 Hardware Connection using I-jet

*1: Figure 3.2.1.1 shows an example when the evaluation board (S5U1C31xxxTx) works using 5V power supply supplied from a debug probe (I-jet).

For more information on the connection of hardware with I-jet, refer to the “IAR Debugging probes User Guide”, “S5U1C31xxxTx Manual” (listed in Table 2.2.1) as necessary.
3. Setup of Development Environment

3.2.2 When Using the J-Link

(1) Connect J-Link to the PC with either IAR EWARM or MDK-ARM installed, using the USB cable included with J-Link. This enables the PC to automatically install the device driver.

(2) Connect J-Link to the evaluation board(ex. S5U1C31xxxTx) using 20-pin ribbon cable included with J-Link. (see Figure 3.2.2.1)

(3) To supply the 5V power supply from J-Link to the evaluation board, set up J-Link in the following procedure. When supplying the power to the evaluation board with the external power supply, the following procedure is unnecessary.

   (3.1) Download “J-Link Software and Documentation Pack” of Ver.6.xx or later from the SEGGER website.

   (3.2) Click “J-Link Software and Documentation Pack (*.exe)” to install it.

   (3.3) Click [SEGGER – J-Link V6.xx > J-Link Commander V6.xx] in the start menu on Windows. Then the console screen will be displayed. (see Figure 3.2.2.2)

   (3.4) Enter the following commands into the console screen.

       J-Link> power on perm
       J-Link> exit

Figure 3.2.2.1 Hardware Connection using J-Link*1

*1: Figure 3.2.2.1 shows an example when the evaluation board (S5U1C31xxxTx) works using 5V power supply supplied from a debug probe (J-Link).
3. Setup of Development Environment

Figure 3.2.2.2 Starting J-Link Commander

For more information on the connection of the hardware with J-Link, refer to the “J-Link/J-Trace User Guide”, “S5U1C31xxxTx Manual” and “S5U1C31001L1100 (Bridge Board Ver.2) Manual” (listed in Table 2.2.1) as necessary.
4. Software Development and Evaluation

This chapter describes the method to build and debug the software using the sample software and the evaluation board provided by Seiko Epson.

4.1 Setup of Sample Software

This section describes the procedure to install the sample software. Before newly developing S1C31 Family software, install the sample software in advance.

1. Download the S1C31xxx Peripheral Circuit Sample Software Package (.zip) from Seiko Epson microcontroller web site, and unzip it to the desired folder.

2. Select "s1c31xxxxsp_verx_xx_xxxxxx.exe" from the destination folder, and select "Run as administrator" from the right-click menu.

3. After launching the installer, execute the installation according to the installer's instructions.
   1. Check the installation contents.
   2. Confirm the term in the software license agreement.
   3. Select installation destination folder and execute installation.

![Figure 4.1.1 Installation Screens]
4. Software Development and Evaluation

(4) When the installation is complete, the setup tool (S1C31xxx toolchain integration utility) starts automatically. Follow the instructions in this tool to complete the setup:

1. Check the setup contents.
2. Select the IDE to be set up.
3. Select the debug probe (only when MDK-ARM is selected).

Note: The setup tool copies various configuration files, definition files and flash loaders, etc. required to develop software on the IDE to the IDE installation folder.

(6) Finally, finish the setup tool and installer.

For more information on the sample software, refer to the “S1C31xxx Peripheral Circuit Sample Software Manual” (listed in Table 2.2.1).
4. Software Development and Evaluation

4.2 Build and Debug of Software

This section describes how to build and debug the software.

4.2.1 When Using the IAR EWARM

(1) Launch the IAR EWARM

Click the [IAR Systems > IAR Embedded Workbench for ARM 8.xx] > IAR Embedded Workbench] in the start menu on Windows to launch the IAR EWARM.

(2) Open the workspace

Select the menu [File > Open Workspace...] to open the following workspace.

“C:\EPSON\s1c31xxxsp_verx_xx_xxxxxx\Examples\WORKSPACE\S5U1C31xxxTx\IARExamples.eww”

(3) Select the active project

Select the desired project to be active from the drop-down list at the top of the [Workspace] window (Figure 4.2.1.1).

As shown below, each sample software project contains three build configurations.

- **Debug** - Build configuration to execute code in internal RAM memory. The optimization level is set to “low”.
- **DebugFlash** - Build configuration to execute code in internal flash memory. The optimization level is set to “low”.
- **ReleaseFlash** - Build configuration to execute code in internal flash memory. The optimization level is set to “high”.

![Figure 4.2.1.1 Selecting the Active Project](image)

Select the target sample software project from the drop-down list and set the project as active.

The active project is displayed in boldface.
4. Software Development and Evaluation

(4) Set the debug probe

Follow the steps below to select the driver for the debug probe you use.

1. Select the menu [Project > Options…].
2. Select the [Debugger] in the [Category] list on the [Options for node “{project}”] dialog (Figure 4.2.1.2).
3. Select the [Setup] tab, and then select the debug probe in the [Driver] drop-down list as shown below (Figure 4.2.1.2).
   - When using the I-jet, select the “I-jet/JTAGjet”.
   - When using the J-Link, select the “J-Link/J-Trace”.

![Diagram showing debug probe setup](image-url)
(5) Set the flash loader

When the build configuration of the active project is DebugFlash or ReleaseFlash, it is necessary to set a flash loader to load the program in the internal flash memory. By default, the flash loader is set. If the flash loader is not set, follow the steps below to set the flash loader.

1. Select the menu [Project > Options…].
2. Select the [Debugger] in the [Category] list on the [Options for node “{project}”] dialog (Figure 4.2.1.3).
3. Select the [Download] tab (Figure 4.2.1.3).
4. Enable the [Use flash loader(s)] checkbox (Figure 4.2.1.3).
5. Enable the [Override default .board file] checkbox (Figure 4.2.1.3).
6. Click the […] button and select a “S1C31xxx_int.board” (Figure 4.2.1.3).

![Figure 4.2.1.3 Setting the Flash Loader](image)

When loading a program into flash memory and executing it, enable the check boxes indicated by the arrow and click the […] button to select the “.board” file that corresponds to the desired flash loader.
4. Software Development and Evaluation

(6) Build the active project

Select the menu [Project > Make] to build the active project (Figure 4.2.1.4).

Note: If linker errors occur in the build of the active project, a possibility that the library projects “sePeriphLibrary” and “seGraphicsLibrary” are not built. Select the library projects with the same build configuration as the active project and build it, and then build the active project again. For example, to build the active project “LCD32B-Debug”, build “sePeriphLibrary-Debug” and “seGraphicsLibrary-Debug”.

(7) Download and Debug the active project

Select the menu [Project > Download and Debug] or click the (Download and Debug) button on the tool bar to start debugging (Figure 4.2.1.4).

For more information on the build operations, refer to the “IDE Project Management and Building Guide” (listed in Table 2.2.1) as necessary. For more information on the debug operations, refer to the “C-SPY® Debugging Guide” (listed in Table 2.2.1) as necessary.
4. Software Development and Evaluation

4.2.2 When Using the MDK-ARM

(1) Launch the MDK-ARM (uVision)
   Click the [Keil uVision5] shortcut icon on the desktop to launch uVision which is IDE provided by MDK-ARM.

(2) Open the workspace
   Select the menu [Project > Open Project...] to open the following workspace.
   “C:\EPSON\s1c31xxxxsp_verx_xx_xxxxxx\Examples\WORKSPACE\S5U1C31xxxTx\ARM Examples.uvmpw”

(3) Select the active project
   Select the desired project in [Project] window and select the [Set as Active Project] in right-click menu (Figure 4.2.2.1). Next, select the build configuration from the drop-down list on the tool bar (Figure 4.2.2.2).

As shown below, each sample software project contains two build configurations.

- Debug - Build configuration to execute code in internal RAM memory
- DebugFlash - Build configuration to execute code in internal flash memory

![Figure 4.2.2.1 Selecting the Active Project](image1)

![Figure 4.2.2.2 Selecting the Build Configuration](image2)
4. Software Development and Evaluation

(4) Set the debug probe

Follow the steps below to select the driver for the debug probe you use.

1. Select the menu [Project > Options for {project} - Target '{build configuration}’].
2. Select the [Debug] tab in the [Options for Target '{build configuration}’] dialog.
3. Select the “J-Link/J-TRACE Cortex” from the drop-down list at the right side of [Use:] checkbox (Figure 4.2.2.3).
4. Click the [Settings] button at the right side of the above drop-down list (Figure 4.2.2.3).
5. Select “SW” from the [Port:] drop-down list in the [Cortex JLink/JTrace Target Driver Setup] dialog box (Figure 4.2.2.4).
6. Click the all [OK] button to close all dialogs.

Note: This setting needs to be done with J-Link connected to the PC.

![Figure 4.2.2.3 Setting the Debug Probe-1](image-url)
Figure 4.2.2.4 Setting the Debug Probe-2
4. Software Development and Evaluation

(5) Set the debug.ini file

When the build configuration of the active project is Debug, follow the steps below to set debug.ini file.

1. Select the menu [Project > Options for {project name} > Target '{build configuration}’].
2. Select the [Debug] tab in the [Options for Target '{build configuration}’] dialog.
3. Click the [...] button at the right side of the [Initialize File] edit box and select “debug.ini” file (Figure 4.2.2.5).
4. Click the all [OK] button to close all dialogs.

![Figure 4.2.2.5 Setting the “debug.ini” File](image-url)
4. Software Development and Evaluation

(6) Set the flash loader

When the build configuration of the active project is DebugFlash, it is necessary to set a flash loader to load the program in the internal flash memory. By default, the flash loader is set. If the flash loader is not set, follow the steps below to set the flash loader.

1. Select the menu [Project > Options for {project name} - Target '{build configuration}’].
2. Select the [Utilities] tab in the [Options for Target ‘{build configuration}’] dialog and then click the [Settings] button in the [Configure Flash Menu Command] group box (Figure 4.2.2.6).
3. Select the [Flash Download] tab in the [Cortex JLink/JTrace Target Driver Setup] dialog. Delete all the flash loader displayed in the [Programming Algorithm] list by clicking the [Remove] button (Figure 4.2.2.7). Next, click the [Add] button to select the flash loader (Figure 4.2.2.8).
4. Select a flash loader “S1C31xxxint ***kB Flash” in the list on the [Add Flash Programming Algorithm] dialog and then click the [Add] button (Figure 4.2.2.9).
5. Enable the checkboxes, [Erase Sectors], [Program] and [Verify], in the [Download Function] group box, and disable other checkboxes (Figure 4.2.2.10).
6. Click the all [OK] button to close all dialogs.

Figure 4.2.2.6 Setting the Flash Loader-1
4. Software Development and Evaluation

Figure 4.2.2.7 Deleting the Flash Loader

Figure 4.2.2.8 Adding the Flash Loader
4. Software Development and Evaluation

Figure 4.2.2.9 Selecting the Flash Loader

Figure 4.2.2.10 Setting the Download Function
4. Software Development and Evaluation

(7) Build the active project

Select the menu [Project > Rebuild ‘{project name} ({build configuration})’] to build the active project (Figure 4.2.2.11).

Note: If linker errors occur in the build, there is a possibility that the library projects “sePeriphLibrary” and “seGraphicsLibrary” are not built. Build these library projects, and then build the active project again.

Figure 4.2.2.11 Build the Active Project
(8) Download and Debug the active project

Select the menu [Flash > Download] to download the active project to the target board (Figure 4.2.2.12). Next, select the menu [Debug > Start/Stop Debug Session] to start debugging (Figure 4.2.2.13).

Figure 4.2.2.12 Download the Active Project

Figure 4.2.2.13 Debug the Active Project

For more information on the build and debug operations, refer to the “Complete User’s Guide Selection” (listed in Table 2.2.1) as necessary.
## Revision History

<table>
<thead>
<tr>
<th>Rev. No.</th>
<th>Date</th>
<th>Page</th>
<th>Category</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rev. 1.0</td>
<td>04/25/2017</td>
<td>All</td>
<td>New</td>
<td>New establishment</td>
</tr>
<tr>
<td>Rev. 2.0</td>
<td>08/03/2017</td>
<td>6-9</td>
<td>Modify</td>
<td>Modified section 3.2 and 3.3 to support ENVPP pin and Bridge Board Ver.2.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>19</td>
<td>Add</td>
<td>Added a step of “Set the debug.ini file” into section 4.2.2.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>24</td>
<td>Modify</td>
<td>Modified a step (7) in section 4.2.2.</td>
</tr>
<tr>
<td>Rev. 3.0</td>
<td>07/05/2019</td>
<td>All</td>
<td>Delete</td>
<td>Deleted the description related Flash Programming Power Supply.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>9,10</td>
<td>Modify</td>
<td>Modified section 4.1 completely for the change of the sample software installation method.</td>
</tr>
</tbody>
</table>