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Evaluation board/kit and Development tool important notice 
1. This evaluation board/kit or development tool is designed for use for engineering evaluation, demonstration, 

or development purposes only. Do not use it for other purposes. It is not intended to meet the requirements of 
design for finished products. 

2. This evaluation board/kit or development tool is intended for use by an electronics engineer and is not a 
consumer product. The user should use it properly and in a safe manner. Seiko Epson dose not assume any 
responsibility or liability of any kind of damage and/or fire coursed by the use of it. The user should cease to 
use it when any abnormal issue occurs even during proper and safe use. 

3. The part used for this evaluation board/kit or development tool may be changed without any notice. 
 
 
NOTICE 
No part of this material may be reproduced or duplicated in any form or by any means without the written 
permission of Seiko Epson.  Seiko Epson reserves the right to make changes to this material without notice.  
Seiko Epson does not assume any liability of any kind arising out of any inaccuracies contained in this material 
or due to its application or use in any product or circuit and, further, there is no representation that this material is 
applicable to products requiring high level reliability, such as, medical products.  Moreover, no license to any 
intellectual property rights is granted by implication or otherwise, and there is no representation or warranty that 
anything made in accordance with this material will be free from any patent or copyright infringement of a third 
party. When exporting the products or technology described in this material, you should comply with the 
applicable export control laws and regulations and follow the procedures required by such laws and regulations. 
You are requested not to use, to resell, to export and/or to otherwise dispose of the products (and any technical 
information furnished, if any) for the development and/or manufacture of weapon of mass destruction or for other 
military purposes. 
 
All brands or product names mentioned herein are trademarks and/or registered trademarks of their respective 
companies. 
ARM and Cortex are registered trademarks of ARM Limited (or its subsidiaries) in the EU and/or elsewhere. 
IAR Systems, IAR Embedded Workbench, C-SPY, I-jet, IAR, and the IAR Systems logotype are trademarks or 
registered trademarks owned by IAR Systems AB. All rights reserved. 
 
“Reproduced with permission from ARM Limited. Copyright © ARM Limited” 
 

©SEIKO EPSON CORPORATION 2017, All rights reserved. 
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1. Overview 

This tool creates a PA file from an ELF file (ROM data). If using the service to load user programs to the internal 
flash memory in S1C31 Family at Seiko Epson’s factory, a PA file must be created and submitted to Seiko Epson. 

The S1C31 Family is microcontrollers, which includes the ARM® Cortex®-M0+ processor, manufactured by 
Seiko Epson Corporation. Software for S1C31 family can be developed using third party ARM® software 
development environment. We recommend the following ARM® software development environments. 

- IAR Embedded Workbench for ARM® (by IAR Systems) 

- MDK-ARM® (by ARM) 

 
1.1 Working Environment 

To use this package, the following conditions are necessary: 

-  PC 

     Windows 7, 8.1 or 10 

-  ARM® development environment 

     IAR Embedded Workbench for ARM® or MDK-ARM®  
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2. Installation 

2.1 Installation instructions 

To install this package, follow the procedure below. 

(1)  Start Windows. 

(2)  Download the S1C31 Family PA File Creation Tool (s1c31_pa_file_creation_tool_vx.xx.zip) from the web 
site of Seiko Epson micro controller, and unzip it in the desired folder. 

(3)  Double-click setup.exe in the desired folder to launch the installer. Then the installation start screen will be 
displayed. 

 

(4)  Click the [Next>] button. Then the software license agreement screen will be displayed. 
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(5)  Read the software license agreement. If you agree to the terms of the license, select “I accept the terms of 
the License Agreement” and click the [Next>] button. Hereafter follow the prompts in the installation wizard 
to proceed with the installation. If you do not agree, click the [Cancel] button to close the installer. 

(6)  When the installation is completed, click the [Finish] button to close the installation wizard. 
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2.2 Structure of installation folder and start menu 

The structure of the installation folder is as follows: 

C:\EPSON (default) 
\C31_PA 
   uninstall.exe    Uninstaller 
   license.txt    License file for this package 
   \TOOL 
      ptd.exe    Motorola-S2-format file conversion tool 
      winmdc17.exe   PA file creation tool 
   \IAR 
      c31_setup.bat          Batch file for setting up this tool for IAR EWARM 
   \ARM 
      c31_setup.bat          Batch file for setting up this tool for MDK-ARM 
   \mcu_model                Folder of the model-specific files for creating PA file 
 

The structure of the start menu folder is as follows: 

EPSON MCU 
C31 PA 
   Create C31 PA file   Shortcut to PA file creation program 
   Setup C31 for IAR   Shortcut to batch file for setting up the PA file creation tool 
                                 (for IAR IDE) 
   Setup C31 for ARM   Shortcut to batch file for setting up the PA file creation tool 
                                 (for MDK-ARM) 
   Uninstall    Shortcut to uninstaller 
   IAR    Shortcut to “C:\EPSON\C31_PA\IAR” folder 
   ARM    Shortcut to “C:\EPSON\C31_PA\ARM” folder 
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3. Registering Tool 

By registering this tool to the IDE(IAR EWARM or MDK-ARM) as external tool, you can create a PA file in the 
IDE. Follow the procedure below to register this tool. 

3.1 Using IAR EWARM 

(1)  Setup the PA file creation tool 

    Right-click the [EPSON MCU] > [C31_PA] > [Setup C31 for IAR] in the start menu and select [Run as 
administrator] to setup the PA file creation tool. 

(2)  Launch the IAR EWARM 

    Click the [IAR Systems] > [IAR Embedded Workbench for ARM 7.xx] > [IAR Embedded Workbench] in 
the start menu to launch the IAR EWARM. 

(3)  Register the PA file creation tool 

  Follow the steps below to register the PA file creation tool as an external tool in the IDE. 

1. Select the [Tools] > [Configure Tools…] in IDE menu to open the [Configure Tools] dialog. 

2. Click the [New] button, and then enter the ‘Create S1C31xxx PA File’(ex. Create S1C31W74 PA File) in 
the text box at the [Menu Text:]. 

3. Click the [Browse…] button at the [Command:], and then select the S1C31xxx_create_pa.bat 
(ex.S1C31W74_create_pa.bat) in C:\EPSON\C31_PA\IAR(default installation folder). 

4. Enter the ‘"$EXE_DIR$" "$PROJ_FNAME$" "$TARGET_FNAME$" "$EW_DIR$"’ in the text box at 
the [Argument:]. 

5. Enter the ‘$EXE_DIR$’ in the text box at the [Initial Directory:]. 

6. Enable the [Redirect to Output Window:] checkboxes. 

7. Disable the [Prompt for Command Line:] checkboxes. 

8. Select the [When not debugging] in the [Tool Available:] drop dawn list. 

9. Click the [OK] button to complete the tool registration.   

Menu Text: Create S1C31XXX PA File 

Command: C:\EPSON\C31_PA\IAR\S1C31xxx_create_pa.bat 

Argument: "$EXE_DIR$" "$PROJ_FNAME$" "$TARGET_FNAME$" "$EW_DIR$"  

Initial Directory: $EXE_DIR$ 

Redirect to Output Window: enable check 

Prompt for Command Line: disable check 

Tool Available: When not debugging 
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3.2 Using MDK-ARM 

(1)  Setup the PA file creation tool 

    Right-click the [EPSON MCU] > [C31_PA] > [Setup C31 for ARM] in the start menu and select [Run as 
administrator] to setup the PA file creation tool. 

(2)  Launch the uVision (MDK-ARM) 

    Click the [Keil uVision5] shortcut icon on the desktop to launch uVision which is IDE included with 
MDK-ARM. 

(3)  Register the PA file creation tool 

  Follow the steps below to register the PA file creation tool as an external tool in the IDE. 

1. Select the [Tools] > [Customize Tools Menu…] in IDE menu to open the [Customize Tools Menu] dialog. 

2. Double-click the blank line in [Menu Content:], and then enter the ‘Create S1C31xxx PA File’(ex. Create 
S1C31W74 PA File). 

3. Click the […] button at the [Command:], and then select the S1C31xxx_create_pa.bat 
(ex.S1C31W74_create_ pa.bat) in “C:\EPSON\C31_PA\ARM”(default installation folder). 

4. Enter the ‘$L’ in the text box at the [Initial Folder:]. 

5. Enter the ‘"$L" "@L" "%L" "$K"’ in the text box at the [Arguments:]. 

6. Disable the checkboxes, [Prompt for Arguments], [Run Minimize] and [Run Independent]. 

7. Click the [OK] button to complete the tool registration. 

Menu Content: Create S1C31XXX PA File 

Command: C:\EPSON\C31_PA\ARM\S1C31xxx_create_pa.bat 

Initial Folder: $L 

Arguments: "$L" "@L" "%L" "$K" 

Prompt for Arguments disable check 

Run Minimized disable check 

Run Independent disable check 
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4. Creating PA File 

If you want to use the service to load the user programs to the internal flash memory of the S1C31 Family at the 
Seiko Epson’s factory, you need to create a PA file and submit it to Seiko Epson. 

Follow the procedure below to create a PA file.  

4.1 Using IAR EWARM 

This section uses the S1C31xxx peripheral circuit sample software provided by Seiko Epson as an example.  

(1)  Open the Workspace 

Launch the IAR EWARM, and then select the [File] > [Open] > [Workspace...] in the IDE menu to open the 
Examples\WORKSPACE\S5U1C31xxxTx\IAR\Examples.eww. 

(2)  Create the ELF file(*.out) 

Set the desired project as active and select the build configuration with “Flash” (ex. DebugFlash or Release 
Flash). Then select the [Project] > [Make] in IDE menu to build the active project. After the build is 
completed, an ELF file (*.out) is created in the “$PROJ_DIR\{build configuration}\Exe” folder. 

(3)  Create the PA file 

Select the [Tools] > [Create S1C31xxx PA File] in IDE menu to create the PA file. 

 
 

When a PA file generation succeeds, the following message is output to the [Tool output] window displayed 
at the bottom of IDE. 

* 

*  OK     PA file is created. 

* 

************************************************************************ 

The PA file (*.PA) is created in the folder where the ELF file(.out) exists. 

 

 

 

  



4. Creating PA File 
 

8 Seiko Epson Corporation S1C31 Family 
PA File Creation Tool Manual 

  (Rev.2.0) 

4.2 Using MDK-ARM 

This section uses the S1C31xxx peripheral circuit sample software provided by Seiko Epson as an example.  

(1)  Open the Workspace 

Launch the uVsion(MDK-ARM), and then select the [Project] > [Open Project…] in the IDE menu to open 
the Examples\WORKSPACE\S5U1C31xxxTx\ARM\Examples.uvmpw. 

(2)  Create the ELF file(*.axf) 

Set the desired project as active and select the build configuration with “Flash” (ex. DebugFlash). Then 
select the [Project] > [Build ‘xxx (yyy)’] in IDE menu to build the active project. After the build is 
completed, an ELF file (*.axf) is created in the $PROJ_DIR\obj\{build configuration} folder. 

(3)  Create the PA file 

Select [Tool] > [Create C31 PA File] in uVision menu to create the PA file. 

 
When a PA file generation succeeds, the following message is output to the [Build Output] window 
displayed at the bottom of IDE. 

* 

*  OK     PA file is created. 

* 

************************************************************************ 

The PA file (*.PA) is created in the folder where the ELF file(.axf) exists. 
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 International Sales Operations 

 

 
AMERICA 
EPSON ELECTRONICS AMERICA, INC. 
214 Devcon Drive, 
San Jose, CA 95112, USA 
Phone: +1-800-228-3964 FAX: +1-408-922-0238 
 
 
 
EUROPE 
EPSON EUROPE ELECTRONICS GmbH 
Riesstrasse 15, 80992 Munich, 
GERMANY 
Phone: +49-89-14005-0 FAX: +49-89-14005-110 
 
 

 
ASIA 
EPSON (CHINA) CO., LTD. 
4th Floor, Tower 1 of China Central Place, 81 Jianguo Road, Chaoyang 
District, Beijing 100025 China  
Phone: +86-10-8522-1199 FAX: +86-10-8522-1120 
 
SHANGHAI BRANCH 
Room 1701 & 1704, 17 Floor, Greenland Center II,  
562 Dong An Road, Xu Hui District, Shanghai, CHINA 
Phone: +86-21-5330-4888     FAX: +86-21-5423-4677 
 
SHENZHEN BRANCH 
Room 804-805, 8 Floor, Tower 2, Ali Center,No.3331 
Keyuan South RD(Shenzhen bay), Nanshan District, Shenzhen 
518054, CHINA 
Phone: +86-10-3299-0588 FAX: +86-10-3299-0560 
 
 
 
EPSON TAIWAN TECHNOLOGY & TRADING LTD. 
14F, No. 7, Song Ren Road,  
Taipei 110, TAIWAN  
Phone: +886-2-8786-6688 FAX: +886-2-8786-6660 
 
 
EPSON SINGAPORE PTE., LTD. 
1 HarbourFront Place, 
#03-02 HarbourFront Tower One, Singapore 098633 
Phone: +65-6586-5500 FAX: +65-6271-3182 
 
 
SEIKO EPSON CORP. 
KOREA OFFICE 
19F, KLI 63 Bldg., 60 Yoido-dong, 
Youngdeungpo-Ku, Seoul 150-763, KOREA 
Phone: +82-2-784-6027 FAX: +82-2-767-3677 
 
 
 
SEIKO EPSON CORP. 
SALES & MARKETING DIVISION 
 
Device Sales & Marketing Department 
421-8, Hino, Hino-shi, Tokyo 191-8501, JAPAN 
Phone: +81-42-587-5816 FAX: +81-42-587-5116 
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